Introduction

Flash is Macromedia’s powerful vector-based animation tool. Flash is the defacto standard for Internet multimedia because it allows authors to create online multimedia presentations with minimum file sizes. With Flash, Web presentations can blend text and pictures with video and audio, interactive buttons, and animated charts and graphs.

Flash is also becoming a rich ground for multimedia because its interactivity lends itself as a medium to non-linear, reader-directed storytelling.

While Flash is used on the most advanced Internet media sites, basic uses, like generating animated slideshows and animating objects, are fairly easy to learn.

First we are going to look at basic shape drawing and animation tools and the workspace.

This tutorial was written for Flash 8, so some of the procedures we describe may be slightly different if you have a newer version of Flash.

Getting Started: The Work Area

Launching Flash will load the work area page. The work area has the following main sections: the toolbar, the stage, and the timeline.
Tools

Selection tools Arrow
- Subselection
- Lasso

Drawing tools Line
- Pen
- Oval
- Text
- Rectangle
- Brush

Transforming tools Transform
- Fill transform
- Inkbottle
- Paintbucket

YOUR BEST FRIEND = Command Z (this erases your previous move)
CLARIFICATION:
A movie is your Flash project, whether a slide show of still photos or bouncing balls, as opposed to a video clip that you might edit in iMovie and put in a Flash movie.

Stage
To change size and color:
Menu > Modify > Document
In the Property Inspector: Change pixels in "size" and color in "background."

To change stage area view:
Menu > View > View Work Area
to toggle between looking at just the stage or seeing the space around the stage

Timeline
It's divided into frames, like a video or animation, with 12 frames per second being the default [but change it to at least 15]. The rectangular red box is the playhead that you move to see changes on the Stage. Play your movie by hitting "Return"

When the Timeline opens:
• It displays one layer with hundreds of little boxes.
• Each box corresponds to a single frame.
• You can make those frames bigger or smaller by clicking the pop-up box at the end of the line of frame numbers (it has what looks like a little Frankenstein scar).
• In the single layer, the first box is outlined in black and contains an empty circle. That first box is a blank keyframe.
• The rest of the boxes are outlined in gray. Boxes with gray outlines are called “protoframes” — they're placeholders. Every fifth protoframe is tinted gray; the rest are white.
• A frame with an empty circle means it is a blank keyframe with nothing in it. Put something in it, and the empty circle changes to a black circle, which indicates a keyframe.

An exercise that explains this:
1. Open a new Flash Document. (Select File/New)
   This default Timeline appears — one layer and one blank keyframe in Frame 1.
   In the New Document dialog box, Flash Document is selected by default

2. Click OK. In the Property inspector, the Size button displays Stage size setting as 550 x 400 pixels.
   The background color swatch is set to white. You can change the color in the Stage by clicking the swatch and selecting a different color.

3. Click on the gray protoframe for Frame 10.

4. From the Insert menu, choose Timeline > Blank Keyframe (or hold down the mouse and select Blank Keyframe from the menu). An empty rectangle appears in Frame 9, and a black line separates Frame 9 from Frame 10. The rectangle indicates the last frame of content for the previous keyframe, and the black line shows where content from one keyframe ends and another begins. Notice that the gray-outlined protoframes 2 through 9 have been replaced with gray tick marks, and all the frames are white.

5. Select the No Color option from the Stroke Color Picker. Select a color of your choice from the Fill Color Picker. Make sure the fill color contrasts with the Stage Color. Click on Frame 1 and, on the Stage, draw a ball (in the tools bar, select the circle tool). Draw a circle. Select the Oval tool and draw one. Hold down the shift key so you have a perfect circle shape.
6. Notice that the empty circle in Frame 1 changes to a black circle, and Frames 1 through 9 – the in-between frames – are tinted gray. This means that Frame 1 has a keyframe with content, and the shading means that the content appears in all the frames from Frame 1 through Frame 9. The empty rectangle signals the last frame that displays Frame 1’s content. Frame 10 still has a blank keyframe that indicates it’s empty. Click on it to see what happens on the Stage.

7. Now, click on Frame 5 and insert a Blank Keyframe. This removes all the content from that frame, and all the frames in-between Frame 5 and Frame 10. This shows that when you insert a keyframe, you’re changing what comes before and what comes after, not just the individual frame that you’ve clicked on.

Note: There are two commands for creating keyframes. When you Insert a Blank Keyframe, you make a keyframe that’s empty so that you can change the contents of the Stage completely. When you insert a Keyframe, it duplicates the content of the preceding keyframe.

6. Click on Frame 3 and choose Insert > Timeline > Keyframe. The contents of Frame 1 are duplicated in Frame 3. The empty rectangle in Frame 4 signals that it’s the last frame in which the content from the previous keyframe in Frame 3 appears.

7. Click on Frame 1 and delete the ball.

8. Click on Frame 3. The ball’s there. When you create a new keyframe as you did in Frame 3, the content becomes completely separate from the previous keyframe’s content. What you do in Frame 1 does not affect the content in Frame 3.

Layers
You put the individual pictures of your project into separate layers. You can have as many layers as you want.
You can:
• Move the layers around: click on layer and drag above or below another layer
• Delete them: click on layer and drag to or click on trash bin just under layer list
• Add more: click on left-most symbol (plus on paper) just under layer list

Top right buttons over the Timeline: **Edit scene** or **edit symbol**
Symbol Editing Mode: This is where you alter the “symbols” in your library

Main work area toggles between two modes:
The **Stage**, where you make your movie, and Editing symbols.

**Windows** (or palettes, located in the main horizontal menu bar):
Make sure the “Properties”, “Library” and “Toolbar” windows are open (find them on the menu in Window).
**Keyframes and Tweening**

Keyframes signify the beginnings and ends of changes in an image (the bounces of a ball, the fade-in of a photo or a fade-out of a photo, etc.). Mark a frame as a keyframe when you want to start or end a change. Think of keyframes as the brackets, the starts and stops, the beginnings and ends -- of a motion, a fade in, a fade out, size increase, a size decrease, etc.

When you set two keyframes -- one when a fade starts, another when it ends, Flash does its magic and figures out the middle, the inbetween part. This is called **TWEENING**.

**Demonstrate Motion Tween:**
1. Open up Flash
2. Stage dimensions = 700 x 500 pixels
3. Background = white
4. Frame rate = 15 fps
5. Before you can manipulate images in Flash, you have to change jpgs to symbols. Flash is very picky about this. Highlight the image and select **Modify/Convert to Symbol**. A handy shortcut is **F8** (Function key 8). In the highlighted box, type boats. Make sure that "graphic" is selected from the choices below. Click "okay", and the jpg on the stage turns into a symbol. [One way you can tell the image on the stage is a symbol is that there's a little circle in the middle of the photo. And, in fact, when you select any of your symbols on the stage, they'll always have the little circle in the middle.]
6. Set the Keyframes: Click on Frame 10, hit Insert > Timeline > Keyframe or hold down the mouse and select Insert Keyframe from the dialog box. OR (easiest:  hit f6)
7. Set the Motion Tweens. This is where you tell Flash how to do the fade -- to set motion tweens between the first two keyframes that bracket the first action to let Flash know that these are the frames in which it has to fill in the action. This is how: Click on Frame 1, hold the mouse down, and when the menu pops up, choose "Create Motion Tween". [Or, you can look in the Property Inspector for "Tween" and choose "Motion" from the drop-down menu.] A thin solid arrow stretches between Frames 1 and 10, indicating a motion tween.
8. Hit return, and watch your movie!

Some more important rules:
**ONLY ONE SYMBOL ON A LAYER.** That means that if you're moving one symbol on a layer, you can't add a symbol to a layer that already has a symbol and make it move independently of the symbol that was there first.

The truth about instances
Flash really works with INSTANCES of symbols. Instances is what you call a symbol after you've dragged it onto the Stage. Why is this important? Because you can do anything you want to this instance -- shrink it, stretch it, make it disappear -- and it doesn't do anything to the symbol from which it came. Which means you can use the symbol as many times as you want.

**Demonstrate Shape Tween.** Turn the circle into a square.

**Shape tweens** are fun because they look really cool and they're easy to create. Compared to motion tweens, they look more dynamic because every attribute -- including the shape -- animates. Basically, all you do is draw one or more shapes in two keyframes and set the tweening in the first keyframe to **Shape**.

1. In a new file, draw a circle on the **Stage**.
2. Insert a keyframe in Frame 30 (remember: **F6**). This will be the end of the tween, and it will match the beginning.
3. Insert keyframe in Frame 15. White the red current-frame marker is on Frame 15, but a little dimple into the circle: Use the Selection tool to first deselect the circle (click off the circle), and then bring the pointer close to the edge until the cursor changes into a curved-tail pointer. Click and drag toward the center of the circle to reshape it.
4. Set shape tweening for the two spands. To do this, click Frame 1, hold Shift, and then Click Frame 15. In the Properties panel, select Shape from the Tween drop-down list.
Tip: Flash is really unforgiving when you don’t follow its rules. Luckily, the rules for a shape tween are very simple: no groups and no symbols. That’s it. Remember these two things, and shape tweens will be easy. Also, Text acts as if it is a grouped or a Drawing Object from the beginning. This means that you can’t use text in a shape tween unless you first break it apart (by selecting Modify, Break Apart). If text contains more than one character, you have to break apart twice – once to break the text into individual characters and another to turn it into individual shapes. Remember, too, that after text becomes a shape it is no longer editable!

Some Tips:
If you ignore all other tips, keeping it simple is the one you really should remember. There are few rules for a shape tween. However, when you have a million different shapes tweening to a million other shapes, the results will look random. The two symptoms that you aren’t keeping it simple are unexpected results and the ‘checkerboard’ effect.

For example, consider these unexpected results. You imagined your name morphing gradually into a circle shape, but despite breaking apart the text you got a mess. Or you go the checkerboard effect in the tweened areas. These are signs that you are creating something too complicated for Flash. So do one thing at a time. For example, try to tween just one letter of your name into a circle.

It's easy to fall in love with the shape tween. There's nothing like it. Feel free to use it when necessary. However, because shape tweens are inherently less efficient and harder to produce than motion tweens (the file sizes are larger and play more slowly), you should always choose motion tweening when you can. If you can get the same effect with either, you should always opt for motion tweening.

Let’s say you have a shape you want to tween from a blue circle to a red square. Only a shape tween will suffice because the actual shape is changing. However, if you just want to tween a blue circle into a red circle, you’re much better off doing it as a motion tween. Draw a circle, convert it to a symbol, insert a keyframe later in the Timeline, use the Properties panel to set Color Effect to tint the circle instance in the second keyframe, and set Tween to Motion when you select the first keyframe. To do the same animation as a shape tween, you would draw a circle (don't convert it to a symbol), insert a keyframe later in the Timeline, fill the circle in the second keyframe with a new color (perhaps using the Bucket tool), and set shape tweening in the first keyframe. The result of each operation is the same, but the motion tween method is better because it gives you only one master version of the circle and therefore a smaller file size.

Sometimes it’s obvious which type of tween is more appropriate. If something's just moving or changing color, a motion tween is appropriate, whereas significant changes to a shape require the shape tween. Sometimes, however, it’s not so obvious. For example, you can drastically change a symbol’s shape by using the Free Transform tool’s Rotate, Scale, and (especially) Skew options. Plus, tweening the properties of a Filter (using Motion Tween) can have a huge impact.

Experiment in Class:
1. Frame Rate: Change Frame rate in your animation from 12 fps to 24 fps and look at the difference.
2. Document Properties: Default is always 550X400, 12 fps unless you decide to change it. Experiment with pixel Width and Height
3. Work with keyframes: try Modify/Timeline/Clear Keyframe
4. Understand the difference between F5, F6, and F7
5. Exercise: Think of a word. As you write it (in brush stroke, say), keep on adding F6 F6 F6 with every stroke of each word. Change the frame rate to experiment.
6. Look at the tiny box on the upper right hand side: you can modify the size of your timeline, BUT you can also preview each frame!
7. Frame rate: adding and deleting frames (f5) can control your frame rate.
8. SHIFT F5 = remove frame

9. Copying frames: Highlight and drag to right (do you see the rectangle box?)...But, as you move it, hold down ALT (Windows) or Option (Mac) and you copy the frames.

10. To REVERSE your frames, highlight the frames, choose Modify/Timeline/Reverse Frames

11. Onion Skinning
   Allows you to see a ghost image of the previous frame so you can see where you want to place the artwork on each frame in relation to the frames before it.
   Select little button, second from right.

12. Flipping an object using the Free Transform Tool.

13. Controller: selecting it and playing your Fla back turns it into a .SWF file.

**Motion Guides**

Please make all 6 symbols move across the frame (you may add more if you like!)

![Image of cartoon dogs]

Above are a bunch of .gif files (all doggies, I'm afraid), which you'll have to convert to SYMBOLS (either Movie or Graphic, NOT Button)

Here’s how you’ll proceed:

1. Create a NEW FLASH DOCUMENT

2. Put the position indicator at the 30-second mark and PRESS the **F6 KEY** to make a "dot" or keyframe for a motion graphic. (you will see a long rectangle with an empty dot on the left end and a little empty rectangle on the right end. Then you see a smaller box (filling just one frame) with just an empty dot.

3. Import all the .gif images that I've attached to this assignment to your library (if you can't see your library, choose Windows/Library)

4. Put the position indicator on the first empty dot. Select a symbol and place it somewhere on your stage: the place where you want to begin your image. Note: the empty white dot now changes to a black dot, signifying that there is something on the stage.

5. Select **Modify/Convert-to-symbol** (choose motion or graphic, but NOT button) and a blue square will surround your symbol.

6. Click on the other black dot. Select the same symbol and position it in the place you want your image to end up.

7. Hit return, and note that your symbol will abruptly change positions as soon as it hits the second black dot.

8. Make sure you have your properties window selected (Windows/properties/properties, or F3).
9. Place your position indicator somewhere in the middle of your timeline.

10. You can now access the Tween button under Properties. Select "Motion."

11. Hit return. Your image will now glide in a straight line between points.

12. Now create a **guide layer**. Look for the symbol with a tiny blue "plus" sign, a semi-circle of red dots, and a little empty blue square. It's under your layer bar. Click on this symbol. A guide layer will appear.


14. Click on the first black dot, and lock your symbol on one side of the guide. Click on the second black dot and lock the symbol on the other side of the guide.

15. Then, place your position indicator in the middle of the timeline, and choose "orient to path" under the Properties Window.

16. Then hit return. Your image should follow the path of the guide. You can choose to hide the guide.

For this assignment, create a herd of animals all meandering across the stage. Change the background to a color other than white. Be as creative as you can/want. Go further in these techniques if you can. What other .gif files can you import into your Library, convert into symbols, and then play with?? Can you import a photograph into the background???

*Spend the rest of class experimenting*